Leadflow Outage

Incident Report for PX

Resolved

A fix has been implemented for the issue affecting PX, and the system is recovering as expected.

Our team is closely monitoring system performance to ensure full stability and reliability across all services. We’re now monitoring performance closely to ensure everything is stable and fully functional. We’ll confirm the final resolution once we’re confident everything is functioning as expected.

Thank you again for your patience during this time.
– The PX Team
Posted Nov 13, 2025 - 06:17 EST

Investigating

We’re experiencing a Leadflow Outage. Our team is currently working to resolve the problem. We apologize for any inconvenience and will post another update as soon as we know more
Posted Nov 13, 2025 - 04:15 EST
This incident affected: PX Ping Post and Direct Post.