Incident

Incident Report for PX

Resolved

We’ve fully resolved the issue that was impacting Lead and call flows on PX. All services are now functioning normally, and system performance is stable.

Our teams will continue to monitor closely, but no further impact is expected. A detailed incident report will follow to share our findings and the steps we’re taking to prevent similar issues in the future.

If you’re still encountering any issues, please don’t hesitate to contact us at support@px.com.

Thank you for your trust and continued partnership.
– The PX Team
Posted Aug 17, 2026 - 08:42 EDT

Investigating

We’re currently investigating an issue on PX that is at least partially impacting our users and partners’ ability to post leads into PX and leads processing by PX platform.

our initial investigation shows that
ping post leads are not delivered to buyers
direct post leads are not delivered to buyers
calls are not delivered to buyers
leads posted by publishers are not arriving
calls posted by publishers are not arriving


Our engineering team is actively working to identify the root cause and restore full functionality as quickly as possible. We understand how critical lead flow and performance visibility are to your business, and we’re treating this with the highest urgency.

We’ll provide updates every 30 minutes or sooner if we have meaningful progress to share.

Thank you for your understanding and continued partnership.
– The PX Team
Posted Aug 17, 2026 - 08:00 EDT
This incident affected: PX Ping Post and Direct Post, PX Calls, Call&Lead, and Branded Flows.