Incident
Incident Report for PX
Resolved
This incident has been resolved.
Posted Jun 28, 2023 - 18:18 EDT
Update
We are continuing to investigate this issue.
Posted Jun 28, 2023 - 18:01 EDT
Investigating
We’re partly experiencing a service outage. Platform users may experience login issues as well as delayed lead processing times. Our team is currently working to resolve the problem. We apologize for any inconvenience and will post another update as soon as we know more. Please keep an eye on this status page. You can always contact support@px.com for any requests.
Posted Jun 28, 2023 - 17:23 EDT
This incident affected: PX Ping Post and Direct Post, PX Calls, Call&Lead, OpenPX (open.px.com), Branded Flows, PX Open API, and Lead Score API.