Incident

Incident Report for PX

Postmortem

Following the deployment of a new PX software release, we started experiencing slowness on PingPost. This was related to changes in our caps management — the calculations introduced in the release caused unexpected behaviour in performance that led to delays in internal traffic processing leading to leads not being delivered.

Our team started to work immediately  to locate and fix the bottlenecks. While some of these efforts led to  improvements, they were not enough to restore full system performance. Eventually, we made the decision to roll back to the previous version of our software. This resolved the issue and restored performance to normal.

We apologize for the disruption today and for not meeting our own standards — or yours.  Thank you for your patience and your trust.

Posted Apr 02, 2025 - 08:32 EDT

Resolved

This incident has been resolved.
Posted Apr 01, 2025 - 11:44 EDT

Monitoring

A fix has been implemented and we are monitoring the results.
Posted Apr 01, 2025 - 11:40 EDT

Identified

The issue has been identified and a fix is being implemented.
Posted Apr 01, 2025 - 10:03 EDT

Investigating

We’re partly experiencing platform slowness. Some clients may notice longer than usual responses on PX API. Our team is currently working to resolve the problem. We apologize for any inconvenience and will post another update as soon as we know more. Please keep an eye on this status page. You can always contact support@px.com for any requests.
Posted Apr 01, 2025 - 09:21 EDT
This incident affected: PX Ping Post and Direct Post, PX Calls, Call&Lead, and Branded Flows.