Performance issues
Incident Report for PX
Resolved
This incident has been resolved.
Posted Dec 18, 2023 - 11:40 EST
Identified
The issue has been identified and a fix is being implemented.
Posted Dec 18, 2023 - 11:26 EST
Investigating
We’re experiencing User interface service degradation. Some users may experience delayed page loading or login issues. Our team is currently working to identify and resolve the problem. We apologize for any inconvenience and will post another update as soon as we know more. Please keep an eye on this status page.
You can always contact support@px.com for any requests.
Posted Dec 18, 2023 - 08:14 EST