Incident
Incident Report for PX
Resolved
This incident has been resolved.
Posted Jan 22, 2024 - 08:40 EST
Monitoring
Our team implemented fix and lead traffic is resumed. We are monitoring the platform to ensure its stability.
Posted Jan 22, 2024 - 08:39 EST
Investigating
We’re experiencing a service degradation. Clients may see delays with lead processing. Our team is currently working to resolve the problem. We apologize for any inconvenience and will post another update as soon as we know more. Please keep an eye on this status page. You can always contact support@px.com for any requests.
Posted Jan 22, 2024 - 06:45 EST
This incident affected: PX Ping Post and Direct Post, PX Calls, Call&Lead, and OpenPX (open.px.com).