Service slowness
Incident Report for PX
Resolved
This incident has been resolved.
Posted Dec 14, 2023 - 07:20 EST
Investigating
We are currently experiencing a higher than normal amount of load on the platform, which may cause pages to be slow or unresponsive. We’re investigating the cause and will provide an update as soon as we know more. Please keep an eye on this status page.
You can always contact support@px.com for any requests.
Expected time for resolution: <> EST.
Posted Dec 14, 2023 - 06:21 EST
This incident affected: OpenPX (open.px.com).