Performance issues
Incident Report for PX
Resolved
The incident was resolved at 15:350 EST
Posted Nov 20, 2024 - 17:43 EST
Identified
The issue has been identified and a fix is being implemented.
Posted Nov 20, 2024 - 15:00 EST
Investigating
We experienced Call Ping service degradation. Some publisher might experienced longer than usual call ping durations.
Posted Nov 20, 2024 - 14:32 EST
This incident affected: Call&Lead.