PX API Performance issues
Incident Report for PX
Resolved
This incident has been resolved.
Posted May 25, 2023 - 09:20 EDT
Investigating
We’re experiencing minor PX API slowness. Small percentage of inbound leads may have increased processing time. Our team is currently working to identify and resolve the problem. We apologize for any inconvenience and will post another update as soon as we know more. Please keep an eye on this status page.
You can always contact support@px.com for any requests.
Posted May 25, 2023 - 06:40 EDT
This incident affected: PX Ping Post and Direct Post.