Incident
Incident Report for PX
Resolved
This incident has been resolved.
Posted Aug 02, 2023 - 08:12 EDT
Identified
Our partner Tune has issues and therefore PX tracking links can be unresponsive. Our team is currently working with Tune to resolve the problem as soon as possible. We apologize for any inconvenience and will post another update as soon as we know more. Please keep an eye on this status page. You can always contact support@px.com for any requests.
Posted Aug 02, 2023 - 06:12 EDT
This incident affected: Branded Flows.