Service slowness
Incident Report for PX
Resolved
This incident has been resolved.
Posted May 16, 2023 - 18:14 EDT
Monitoring
The performance issue (slowness) was fixed. We are currently monitoring the platform to make sure everything works properly.
Posted May 16, 2023 - 17:41 EDT
Investigating
We are currently experiencing a higher than normal amount of load on the platform, which may cause pages to be slow or unresponsive. We’re investigating the cause and will provide an update as soon as we know more. Please keep an eye on this status page.
You can always contact support@px.com for any requests.
Expected time for resolution: <> EST.
Posted May 16, 2023 - 17:21 EDT
This incident affected: OpenPX (open.px.com).