Incident
Incident Report for PX
Resolved
The PX platform is fully operational. The issue has been resolved.
Downtime: 3:30 PM - 4:15 PM EST
Posted Jul 26, 2023 - 16:27 EDT
Update
We are continuing to work on a fix for this issue.
Posted Jul 26, 2023 - 16:22 EDT
Identified
We have identified and partially fixed the issue. The users should be able to access the platform now. The lead & call flows are not partially operational.
Posted Jul 26, 2023 - 16:22 EDT
Investigating
We’re experiencing a PX platform outage. Our team is currently working to resolve the problem. The users may experience log-in issues. Lead & Call flows are partially affected as well. We apologize for any inconvenience and will post another update as soon as we know more. Please keep an eye on this status page. You can always contact support@px.com for any requests.
Posted Jul 26, 2023 - 15:49 EDT
This incident affected: PX Ping Post and Direct Post, PX Calls, Call&Lead, OpenPX (open.px.com), Branded Flows, PX Open API, and Lead Score API.