Incident
Incident Report for PX
Resolved
This incident has been resolved.
Posted Feb 20, 2024 - 05:25 EST
Investigating
We’re partly experiencing service outage. Our team is currently working to resolve the problem. We apologize for any inconvenience and will post another update as soon as we know more. Please keep an eye on this status page. You can always contact support@px.com for any requests.
Posted Feb 20, 2024 - 04:00 EST
This incident affected: PX Ping Post and Direct Post, PX Calls, Call&Lead, OpenPX (open.px.com), and Branded Flows.